Comments

3 comments

  • John Lockburner

    In the cameras menu there is a setting to turn the beep off. If you're camera is doing that you also probably need to update the firmware.

    0
    Comment actions Permalink
  • brian BURY

    did both already.  that's what started the beeping

    0
    Comment actions Permalink
  • John Lockburner

    Try defaulting the settings and then after the camera restarts turn the beep off, You might have to hit the OK button after turning it off to finalize the change. What date is the firmware the camera is showing on it's screen and what model is the camera?

    0
    Comment actions Permalink

Please sign in to leave a comment.