SIM CARD ACTIVATION

Comments

8 comments

  • John Lockburner

    It usually doesn't take too long. Make sure to check your spam folder too. It won't hurt to turn the camera on and see if it finds signal and then go into the menu to diagnostics and try the hello test. If it passes your plan is active.

    0
    Comment actions Permalink
  • Matt Aberle

    Well I paid for the data plan this morning. Have not received an email and my SIM card wont connect.  I did check my Junk Mail, unfortunately nothing. Thank you.  Any other ideas by chance

    0
    Comment actions Permalink
  • Elizabeth Swoope

    You can also log on to your account at my.spartancamera.com, Account, Wireless Subscriptions. It will say pending or active. Once it’s active, you’re good.

    0
    Comment actions Permalink
  • Elizabeth Swoope

    Is this for a Verizon camera or an AT&T one? Sometimes the Verizon ones have to be activated manually in the office so it takes a little more time.

    0
    Comment actions Permalink
  • Matt Aberle

    It is an At&T Camera - online it says it is active Just tried to Hello test and failed. 

    0
    Comment actions Permalink
  • Matt Aberle

    Now it says, (register fail) instead of (No sim Card)

    0
    Comment actions Permalink
  • John Lockburner

    Default the camera in it's menu and try again. You'll get the sim card error when there's no active plan

    0
    Comment actions Permalink
  • Elizabeth Swoope

    I know you’re going to think this is weird, but please double-check your SD card.

    https://support.spartancamera.com/hc/en-us/articles/360040555453-SD-card-information-and-recommendations

    0
    Comment actions Permalink

Please sign in to leave a comment.