GoCam gc-g4gb not registering

Comments

12 comments

  • John Lockburner

    You bought the plans through Spartan correct? And you got a separate data plan for each camera?

    0
    Comment actions Permalink
  • Richard Walker

    Yes that is correct. Entered the IMEI number for each camera that I purchased the data plan for. 

    0
    Comment actions Permalink
  • John Lockburner

    Look at your account on the online portal and make sure it shows three separate data plans active. Also if you are trying the camera inside maybe give it a try outside and make sure that the antenna is attached.

    0
    Comment actions Permalink
  • Richard Walker

    Yes separate “active” plans with the correct numbers on each plan. Inside or outside same thing

    0
    Comment actions Permalink
  • John Lockburner

    How long ago did you purchase the plans?

    0
    Comment actions Permalink
  • Richard Walker

    Just today around 2 hours ago

    0
    Comment actions Permalink
  • Richard Walker

    At 2pm

    0
    Comment actions Permalink
  • John Lockburner

    Sometimes it can take some time, you might want to give it a little longer or send and email to tech with the Sim card numbers and the cameras IMEI numbers so they can check on things.

    0
    Comment actions Permalink
  • Richard Walker

    Where is the SIM card located on these cameras? I can not find a slot for it. Just an sd card

    0
    Comment actions Permalink
  • John Lockburner

    It's internal and not user accessible

    0
    Comment actions Permalink
  • Richard Walker

    Ok. Got the camera to come on this morning and activate. However it will not send pics or even take them on the sd card. The other camera is still fading off when screen comes on. I feel that camera needs repair or replacement as it will not stay on for me to do anything

    0
    Comment actions Permalink
  • John Lockburner

    The Ghost will arm itself after 3 minutes when you turn it on and the screen will go black. Once you turn the camera on and it finds signal, press the OK button to take a picture and press it again to send the picture, watch what happens and what it says on the screen. It should eventually say sent or give you an error.

    0
    Comment actions Permalink

Please sign in to leave a comment.