On button

Comments

4 comments

  • John Lockburner

    If it's less than two years old it's under warranty and you can send it back. You can try moving the switch back and forth really fast and see if that helps, sometimes it's just a little corrosion on the switch.

    0
    Comment actions Permalink
  • Andrew Lester

    John, I’ll just send it back. I have tried to find some sort of method to make it work but it won’t. What address should i mail it to?

    0
    Comment actions Permalink
  • John Lockburner

    Send an email to support@spartancamera.com and tell them you need an RMA for a faulty switch.

    0
    Comment actions Permalink
  • Elizabeth Swoope

    If the camera is no longer under warranty, you can try this to clean the switch. 

    1. Remove batteries and SD card.
    2. Put a piece of tape across the switch and another across the cursor buttons to keep the buttons attached to the inside cover when you remove it.
    3. Unscrew the four tiny screws (one in each corner) holding the inside front cover in place.
    4. Spray electronics contact cleaner on the switch and move the switch back and forth rapidly several times.
    5. After the contact cleaner has dried, put four batteries (two top, two bottom, leftmost side of battery compartment) in the camera, as well as the SD card.
    6. Turn the camera to setup and see if it comes up properly, turns on properly, shuts off properly. If it doesn’t, repeat.
    7. Put everything back together.
    0
    Comment actions Permalink

Please sign in to leave a comment.